Page 1 of 1

"Automatically format on paste" ignores line ending setting

PostPosted: June 22nd, 2017, 5:08 pm
by pocketpc_
I have 'Options > Text Editor > PHP > Advanced > PHP files line endings' set to 'Unix (LF)' for PSR-2 compliance. For some reason, whenever I paste PHP code, all the line endings in the file get set to CRLF. This only happens if 'Options > Text Editor > PHP > Formatting > General > Automatically format on paste' is enabled. If I close and reopen the file, they get set back to LF as they should, but the constant line ending changes are really annoying. I also don't want to have to reformat all my pasted code.