Installation

Discussion about the managed MySql extension [?] for Phalanger.

Installation

Postby jfburns@codeplex » September 13th, 2006, 11:30 am

I followed the installation instructions on this site and I'm getting an error during compilation. Please let me know what I'm doing wrong. I'm using the latest nightly build and Phalanger 2 Beta 2. Thanks!

RUN MYSQL GAC COMMAND:

C:\Program Files\Phalanger v2.0>Bin\gacutil -f -i Bin\PhpNetMySql.dll
Microsoft (R) .NET Global Assembly Cache Utility. Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.

Assembly successfully added to the cache

C:\Program Files\Phalanger v2.0>Bin\gacutil -f -i Bin\MySql.Data.dll
Microsoft (R) .NET Global Assembly Cache Utility. Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.

Assembly successfully added to the cache

C:\Program Files\Phalanger v2.0>Bin\gacutil -f -i Bin\ICSharpCode.SharpZipLib.dll
Microsoft (R) .NET Global Assembly Cache Utility. Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.

Assembly successfully added to the cache

COMPILE EXE:

...

App.config Reading configuration:

<add assembly="PhpNetMySql, Version=2.0.0.0, Culture=neutral, PublicKeyToken=2771987119c16a03" section="mysql"/>

C:\Documents and Settings\Owner\Desktop\project\application\App.config(5,0): error PHP2004: Configuration error: Library assemby 'PhpNetMySql, Version=2.0.0.0 Culture=neutral, PublicKeyToken=2771987119c16a03' could not be loaded. Method not found: 'Void PHP.Core.PhpLIbraryAttribute..ctor(System.Type)'.

App.config:

<configuration>
<phpNet>
<!-- Reference to the extension assembly -->
<classLibrary>
<add assembly="PhpNetMySql, Version=2.0.0.0, Culture=neutral, PublicKeyToken=2771987119c16a03" section="mysql"/>
</classLibrary>
</phpNet>
</configuration>
jfburns@codeplex
 
Posts: 15
Joined: January 7th, 2012, 8:57 pm

RE: Installation

Postby Tomas Matousek » September 17th, 2006, 9:57 pm

The latest nightly build of MySQL is compatible with the latest nightly build of Phalanger, but not with Beta 2 of Phalanger -- for that you need Beta 2 of MySQL.
Tomas Matousek
 
Posts: 17
Joined: January 7th, 2012, 8:52 pm

RE: Installation

Postby TheMaskedFerret@codeplex » January 16th, 2007, 12:21 pm

I am having basically the same problem, except I have Beta 3 of Phalanger 2.0 installed.

Below is my Error message:
-------------------------------------------------------------------------------------------------
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Library assembly 'PhpNetMySql, Version=2.0.0.0, Culture=neutral, PublicKeyToken=2771987119c16a03' could not be loaded. Method not found: 'Void PHP.Core.PhpLibraryAttribute..ctor(System.Type)'.

Source Error:

Line 4: <!-- Reference to the extension assembly -->
Line 5: <classLibrary>
Line 6: <add assembly="PhpNetMySql, Version=2.0.0.0, Culture=neutral, PublicKeyToken=2771987119c16a03" section="mysql"/>
Line 7: </classLibrary>
Line 8: <!-- Optional configuration -->


Source File: c:\inetpub\wwwroot\drupal5\web.config Line: 6

Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210
TheMaskedFerret@codeplex
 
Posts: 3
Joined: January 7th, 2012, 8:56 pm

RE: Installation

Postby snagpaul@codeplex » March 3rd, 2007, 5:23 am

I am also using Beta 3 of Phalanger 2.0 and getting the same error. Has anybody got a fix for this?
snagpaul@codeplex
 
Posts: 1
Joined: January 7th, 2012, 8:59 pm

RE: Installation

Postby alley@codeplex » March 23rd, 2007, 1:39 pm

You can build the source version, it works.

I also placed a read-build version in the issuetracker, please mind
the version number change:

http://www.codeplex.com/PhalangerMySQL/WorkItem/View.aspx?WorkItemId=9107
alley@codeplex
 
Posts: 2
Joined: January 7th, 2012, 8:59 pm

RE: Installation

Postby reygieceliz@codeplex » November 18th, 2009, 2:02 am

hi! i have also the same problem i am having problem with the mysql_connect() it somehow not working with the phalanger, also our application is using the mysqli extension which we can used the stored procedure in mysql but unfortunately phalanger have no support for the extension library for this.

By d way i am using the phalanger 2.0 with mysql latest nightly build.

It could be better if u could post here a step by step setup and requirement to run the phalanger and mysql successfully.

i hope u could reply to this thread because we are planning to used this phalanger to our application.

thanks and god bless, 

reygieceliz@codeplex
 
Posts: 1
Joined: January 7th, 2012, 8:59 pm

RE: Installation

Postby Jakub Misek » December 14th, 2010, 11:53 pm

Hi,

we didn't notice, sorry. The extension is fixed and updated now to work with the latest Phalanger 2.0. You can download and install the release without any problems now.

Best Regards,
Jakub 

Jakub Misek │ DEVSENSE s.r.o. │ Email: jakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2056
Joined: January 4th, 2012, 2:42 pm
Location: Prague

RE: Installation

Postby tcltkdev@codeplex » January 13th, 2011, 6:49 am

Newbie here. I'm getting this error on the console:

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL

client in C:\Documents and Settings\Administrator\Desktop\Console App Test\ConsoleAppTest\ConsoleAppTest\Program.php at
expression on line 12, column 1.

I'm using Phalanger 2.0 (January 2011) and MySQL Phalanger 2.0 (January 2011) with Visual Studio 2008 on WinXP.

Please help.

tcltkdev@codeplex
 
Posts: 3
Joined: January 7th, 2012, 8:38 pm

RE: Installation

Postby Jakub Misek » January 13th, 2011, 1:26 pm

Hi tcltkdev,

the extension uses MySQL Connector/Net 6.3.5 (http://dev.mysql.com/downloads/connector/net/). According to their specifications, it supports MySQL 5.0, 5.1, 5.4, 5.5.

The error message was probably thrown by the MySQL server. Are you using SSL ? Because as I noticed now, this option was not enabled in our extension yet.

Best Regards,
Jakub 

Jakub Misek │ DEVSENSE s.r.o. │ Email: jakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2056
Joined: January 4th, 2012, 2:42 pm
Location: Prague

RE: Installation

Postby Jakub Misek » January 26th, 2011, 12:22 pm

This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jakub Misek │ DEVSENSE s.r.o. │ Email: jakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2056
Joined: January 4th, 2012, 2:42 pm
Location: Prague


Return to MySql Extension project

Who is online

Users browsing this forum: No registered users and 1 guest

User Control Panel

Login

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 62 on January 7th, 2012, 10:54 pm

Users browsing this forum: No registered users and 1 guest
Phalanger