Wordpress WP.net Visual Studio localhost wont run index.php

Discussion about the open-source Phalanger [?] project.

Wordpress WP.net Visual Studio localhost wont run index.php

Postby Madde » December 13th, 2012, 2:58 pm

Hi

I have downloaded and setup WordPress.
It was all fine until i was done to test it.
Visual Studio localhost wont run the index file.
It's just the: Directory Listing -- /wpdotnet/ page.
It's possible to run the wpdotnet/wp-admin/index.php but not the wpdotnet/index.php file. It just throw me back to Directory Listing page.
Please Help
Madde
 
Posts: 7
Joined: December 13th, 2012, 2:50 pm

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Jakub Misek » December 13th, 2012, 3:37 pm

Hi,

WordPress checks the URL and redirects you automatically to root dir in case of index.php file.

You have to add defaultDocument configuration.

Add following into your web.config, into <configuration><system.webServer>
Code: Select all
<defaultDocument>
    <files>
        <add value="index.php" />
    </files>
</defaultDocument>
Jakub Misek │ DEVSENSE s.r.o. | @misekjakubjakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2092
Joined: January 4th, 2012, 2:42 pm
Location: Prague

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Madde » December 14th, 2012, 7:29 am

Thanks!

Makes all sense but

this is already in there:

Code: Select all
    <defaultDocument>
      <files>
        <remove value="index.php"/>
        <add value="index.php"/>
      </files>
    </defaultDocument>
Madde
 
Posts: 7
Joined: December 13th, 2012, 2:50 pm

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Jakub Misek » December 14th, 2012, 4:04 pm

It is :? but IIS is still not handling index.php as a default document.

What is your web server ? IIS, IIS Express, Apache ? It would be related to specific version of your server.
Jakub Misek │ DEVSENSE s.r.o. | @misekjakubjakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2092
Joined: January 4th, 2012, 2:42 pm
Location: Prague

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Madde » December 17th, 2012, 8:02 am

It's Visual Studio Developer Server.
It's working on the usual IIS.

Just visual Studio that's the problem.

But it's Ok i use the usual iis instead.
Madde
 
Posts: 7
Joined: December 13th, 2012, 2:50 pm

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Jakub Misek » December 17th, 2012, 6:42 pm

I don't know how to set default document on VS dev server ... there should be a way ...
Jakub Misek │ DEVSENSE s.r.o. | @misekjakubjakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2092
Joined: January 4th, 2012, 2:42 pm
Location: Prague

Re: Wordpress WP.net Visual Studio localhost wont run index.

Postby Madde » December 20th, 2012, 12:12 pm

Yes you just right click on the file and click set default document but it's not an option on php files. but the Web.config trick should do it but i don't know why it doesn't work.
Madde
 
Posts: 7
Joined: December 13th, 2012, 2:50 pm


Return to Phalanger project

Who is online

Users browsing this forum: No registered users and 2 guests

cron

User Control Panel

Login

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 151 on December 6th, 2020, 7:46 am

Users browsing this forum: No registered users and 2 guests