PHpunit

PHP Tools [?] extends Visual Studio with set of advanced features to work more efficiently with PHP code.

PHpunit

Postby joaomfrebelo » December 19th, 2018, 10:26 pm

I'm trying to run test with phpunit and i'm having this error:

Declaration of PhpTestingPrinter::flush() must be compatible with PHPUnit\Util\Printer::flush(): void

I have my own phpunit instaled (7.2.5) with composer
joaomfrebelo
 
Posts: 3
Joined: December 19th, 2018, 9:53 pm

Re: PHpunit

Postby maros.beno » December 20th, 2018, 9:18 am

Hi, thank you for letting us know about this. We will take a look and let you know what we find. Have a nice day and merry christmas.
Maroš Beňo
User avatar
maros.beno
 
Posts: 62
Joined: October 12th, 2016, 12:11 pm

Re: PHpunit

Postby Miloslav Beno » December 27th, 2018, 3:17 pm

Hello,

Thank you for the post. The issue is that current version doesn't support phpunit 7.*, but the next update will.

Cheers!
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1252
Joined: January 7th, 2012, 8:36 pm

Re: PHpunit

Postby maros.beno » January 4th, 2019, 12:24 pm

Hi,
it should be fixed in our latest preview.

Thanks again for reporting this and Happy new year.
Maroš Beňo
User avatar
maros.beno
 
Posts: 62
Joined: October 12th, 2016, 12:11 pm


Return to PHP Tools

Who is online

Users browsing this forum: No registered users and 5 guests

cron

User Control Panel

Login

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 89 on October 15th, 2018, 4:06 pm

Users browsing this forum: No registered users and 5 guests