(done) Smarty install

PHP Tools [?] extends Visual Studio with set of advanced features to work more efficiently with PHP code.

(done) Smarty install

Postby Marc » September 7th, 2018, 6:43 pm

Hello,

I might be a very stupid question, but I'm not able to install the Smarty template engine. On a Smarty template file (*.tpl) the info box appears, but when I click Install Now the hourglass appears but nothing happens after it. I waited for about an hour (cooking, eating).

I couldn't find a log file.
I'm working with Visual Studio 2017 Community edition, I'm in the trial license and I haven't installed Xdebug.

Another thing that I came across is that all classes defined in the include_path defined in the php.ini (or in the project properties) are not recognized.

Greetz, Marc
Marc
 
Posts: 2
Joined: September 7th, 2018, 6:34 pm

Re: Smarty install

Postby Jakub Misek » September 9th, 2018, 10:41 am

Hi Marc,

Thanks for trying our tools. Please take a look into VS's Output Window, there should be more details. The installation of the Smarty template engine should take a second.

Usually you don't either have a PHP yet (which is installed for you when you start a project for the first time) or a "composer install" failed for some reason.

We'll check the include_path; only those in project's properties should work. Are you trying relative or absolute paths?

Thanks,
Jakub
Jakub Misek │ DEVSENSE s.r.o. | @misekjakubjakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2085
Joined: January 4th, 2012, 2:42 pm
Location: Prague

Re: Smarty install

Postby Marc » September 9th, 2018, 12:32 pm

Hello Jakub,

How could I miss the output window???

Now I could see Composer was not installed, but although it does automatically it could not because I had not enabled the opensll extension in the php.ini. In the project properties I also found the delimiters for Smarty, which I actually had defined in a base class.

Further, I did not notice that if a file is already open (.tpl or .php) the intellisense errors do not update after updating the settings. So Smarty errors and Classes in the include path did not disappear. Closing the files and reopening them solved it.

Now it's all working fine. Thanx a lot!!

Greetz, Marc

(This topic can be closed)
Marc
 
Posts: 2
Joined: September 7th, 2018, 6:34 pm


Return to PHP Tools

Who is online

Users browsing this forum: No registered users and 5 guests

User Control Panel

Login

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 89 on October 15th, 2018, 4:06 pm

Users browsing this forum: No registered users and 5 guests
Phalanger