(done) Visual Studio 2017 Debugging

PHP Tools [?] extends Visual Studio with set of advanced features to work more efficiently with PHP code.

(done) Visual Studio 2017 Debugging

Postby tthayer » July 24th, 2018, 5:44 pm

Hi,

I have installed a fresh installation of VS 2017 on a Windows 7 box and the immediately installed PHP Tools. Tried the debugging right away on the basic Hello Framework test and debugging does not work at all. It says symbols not loaded. Tried all the settings I know, such as VS repair, disabling and re-enabling JIT, no luck. Also checked the port and I setup my PHP project to use port 9000. Still no luck.

Any suggestions would be greatly appreciated.

Cheers,

Tom
tthayer
 
Posts: 2
Joined: July 24th, 2018, 5:41 pm

Re: Visual Studio 2017 Debugging

Postby samwilcock » July 30th, 2018, 2:00 pm

I have got exactly the same problem, have you had any luck fixing this yet ?
samwilcock
 
Posts: 5
Joined: December 14th, 2015, 10:58 am

Re: Visual Studio 2017 Debugging

Postby tthayer » August 2nd, 2018, 2:16 am

No, nothing. Sorry.
tthayer
 
Posts: 2
Joined: July 24th, 2018, 5:41 pm

Re: Visual Studio 2017 Debugging

Postby Miloslav Beno » August 6th, 2018, 8:24 am

Hi guys,

Have you checked the troubleshooting guide? https://docs.devsense.com/en/debugging/troubleshooting

Please let me know if you can see Xdebug in the phpinfo output.

Thank you,
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1228
Joined: January 7th, 2012, 8:36 pm

Re: Visual Studio 2017 Debugging

Postby samwilcock » August 6th, 2018, 8:31 am

Hi Miloslav,

I have tried the troubleshoot guide and still cannot see xdebug in the phpinfo output.

Sam
samwilcock
 
Posts: 5
Joined: December 14th, 2015, 10:58 am

Re: Visual Studio 2017 Debugging

Postby Miloslav Beno » August 6th, 2018, 8:43 am

Hi Sam,

I see, so Xdebug didn't load - It usually doesn't load because of a wrong dll.

Please send me phpinfo output, I will take a look.

You've installed php through our Automatic installation process, or you've installed another distribution?

Thanks!
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1228
Joined: January 7th, 2012, 8:36 pm

Re: Visual Studio 2017 Debugging

Postby samwilcock » August 6th, 2018, 8:52 am

Hi Miloslav,

I have installed PHP through your Automatic Installation process and when I created my project for the first time I was promted by phptools for it to instll xdebug, but that doesn't seem to have worked.

I have attached my php info output.
You do not have the required permissions to view the files attached to this post.
samwilcock
 
Posts: 5
Joined: December 14th, 2015, 10:58 am

Re: Visual Studio 2017 Debugging

Postby Miloslav Beno » August 6th, 2018, 9:38 am

Hi,

Thank you!

I've found out what the problem is. Microsoft has recently updated Web Platform installer. The new version has a bug which downloads PHP x64 distribution instead of PHP x86. This way it just cannot work. You can workaround this by copying xdebug x64 to ext folder and rename it to "php_xdebug.dll".

For PHP 7.1 x64 download http://xdebug.org/files/php_xdebug-2.6.1-7.1-vc14-nts-x86_64.dll

I'm going to contact Microsoft immediately.

Thanks again for bringing this to our attention.
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1228
Joined: January 7th, 2012, 8:36 pm

Re: Visual Studio 2017 Debugging

Postby samwilcock » August 6th, 2018, 12:06 pm

Hi Miloslav,

This worked thanks !.
samwilcock
 
Posts: 5
Joined: December 14th, 2015, 10:58 am

Re: Visual Studio 2017 Debugging

Postby Miloslav Beno » August 6th, 2018, 12:52 pm

I'm glad. I've contacted a guy from WebPI Team, hopefully they will fix the cause of the bug asap.

Btw. you can visually see the bug when you open Web Platform Installer GUI.

webpi-bug.png
You do not have the required permissions to view the files attached to this post.
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1228
Joined: January 7th, 2012, 8:36 pm

Next

Return to PHP Tools

Who is online

Users browsing this forum: No registered users and 4 guests

cron

User Control Panel

Login

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 89 on October 15th, 2018, 4:06 pm

Users browsing this forum: No registered users and 4 guests
Phalanger