Composer installation of Bootstrap ends with error of -1

PHP Tools [?] extends Visual Studio with set of advanced features to work more efficiently with PHP code.

Composer installation of Bootstrap ends with error of -1

Postby streible » June 6th, 2018, 10:20 am

Hi Everyone,

Since I'm in the midst of teaching myself more about PHP and I've been wanting to use Composer within VS 2017 and when the installation of Bootstrap ends, it ends with a status of "====composer command completed with exit code -1====" and nothing is installed within the project itself, but there are folders created in the directory for the project which pertain to Bootstrap which can be found under "vendor\twbs\bootstrap", so what can one expect to be happening with Composer? Is Composer the equivalent to Nuget in the .NET sense?

If someone could please advise and provide some direction, that would be appreciated.

Thanks,

Steve
streible
 
Posts: 4
Joined: July 9th, 2016, 12:22 pm

Re: Composer installation of Bootstrap ends with error of -1

Postby Miloslav Beno » June 6th, 2018, 6:21 pm

Hi Steve,

yes, composer is basicaly nuget in PHP world.

Please take a look at the output pane (select composer there) to see what happened during installation of bootstrap, there might be some requirements not fulfilled or violated.
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1223
Joined: January 7th, 2012, 8:36 pm

Re: Composer installation of Bootstrap ends with error of -1

Postby streible » July 6th, 2018, 10:25 am

I finally got around to getting back to this after a month since I've had some other things that have needed my attention and whether this is a new project or an existing, this is what I get:

====Executing command 'composer update --no-interaction --no-ansi'====

Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating autoload files

====composer command completed with exit code -1====

Loading composer repository...
Composer repository was successfully loaded.

====Executing command 'composer require "fortawesome/font-awesome" --dev --no-interaction'====

Using version ^4.7 for fortawesome/font-awesome
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
- Installing fortawesome/font-awesome (v4.7.0): Downloading (connecting...)
Downloading (100%)
Writing lock file
Generating autoload files

====composer command completed with exit code -1====

I attempted a simple update of Bootstrap and then installed Font Awesome and it reports the same exit code for both, so I'm not sure what an exit code of -1 means.

Any insight you could provide would be appreciated.

Thanks,

Steve
streible
 
Posts: 4
Joined: July 9th, 2016, 12:22 pm

Re: Composer installation of Bootstrap ends with error of -1

Postby maros.beno » July 10th, 2018, 8:56 am

Hi, I was testing it and Composer reports to me, that that it completed with errors (result -1) as well. But composer package was installed correctly. I guess that it only says there was some error, but there wasn't one. We will look at it more closely, but I think you can ignore it for now, assuming the package installed and it's working for you. Does it?
Thank you for reporting this, if you have any other problems, don't hesitate to write us. Have a nice day.
Maroš Beňo
User avatar
maros.beno
 
Posts: 34
Joined: October 12th, 2016, 12:11 pm


Return to PHP Tools

Who is online

Users browsing this forum: No registered users and 2 guests

cron

User Control Panel

Login

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 77 on September 4th, 2018, 9:46 pm

Users browsing this forum: No registered users and 2 guests
Phalanger