Text / code turns white when using <?php ?>

PHP Tools [?] extends Visual Studio with set of advanced features to work more efficiently with PHP code.

Text / code turns white when using <?php ?>

Postby Refica » April 20th, 2018, 10:55 am

Hi,

I have a problem in Visual Studio 2017 Community version when using PHP Tools.

All text / code turns white when using <?php and then ?>

Please see this short video:
http://cloud.refica.dk/453O2i2n3O1m

If I am starting with ?> and then <?php afterwards there are no problem.

Please see this short video:
http://cloud.refica.dk/1t1i171j191b

Do you have any solution on this problem?

Kind regards,
René
Refica
 
Posts: 1
Joined: April 20th, 2018, 10:43 am

Re: Text / code turns white when using <?php ?>

Postby AndyM84 » April 22nd, 2018, 4:26 am

Is your issue by any chance the same as what we've been discussing here? viewtopic.php?f=21&t=2048
User avatar
AndyM84
 
Posts: 69
Joined: August 6th, 2012, 3:24 pm
Location: Boston, MA, USA

Re: Text / code turns white when using <?php ?>

Postby Miloslav Beno » May 3rd, 2018, 9:28 am

Hi guys,

Thank you for noticing this!

We've identified this issue together with other HTML integration issues for PHP. The solution is full reimplementation of HTML integration just for VS2017. The issue is backward compatibility for older VS. This would basically kill the support for vs2010-vs2015.

Anyway we have this in our todo list and planning to do it.

Thank you!
Miloslav Beno │ DEVSENSE s.r.o. │ @miloslavbenomiloslav@devsense.com
User avatar
Miloslav Beno
 
Posts: 1242
Joined: January 7th, 2012, 8:36 pm


Return to PHP Tools

Who is online

Users browsing this forum: No registered users and 4 guests

cron

User Control Panel

Login

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 89 on October 15th, 2018, 4:06 pm

Users browsing this forum: No registered users and 4 guests
Phalanger