Page 1 of 1

Issues with stepping in debugger.

PostPosted: December 3rd, 2017, 9:27 pm
by WaldemarHasz
Hi guys

Since updating to 1.25.10447 (before I was on 1.23.9750 or 1.24.10137 I don't remember) I have a very, very annoying thing happening... lots of times (90% of the times) I need to press F10 multiple times for the debugger to step just 1 line in code.

Just now I've do a simple test and I had to press F5 13 times for the debugger to continue.

Can you please fix this.

Br
Waldemar

Re: Issues with stepping in debugger.

PostPosted: December 4th, 2017, 11:49 am
by Miloslav Beno
Hi Waldemar,

Thanks for the feedback. Let me take a look at it and get back to you ASAP. If you could provide me with more information e.g. VS version, PHP version or anything that could help me replicate this would be helpful.

Thank you,

Re: Issues with stepping in debugger.

PostPosted: December 4th, 2017, 1:23 pm
by Miloslav Beno
Hi Waldemar,

I wasn't able to replicate. We could try to make online session to check this if you don't mind?

Thanks,

Re: Issues with stepping in debugger.

PostPosted: December 4th, 2017, 11:23 pm
by WaldemarHasz
c

Re: Issues with stepping in debugger.

PostPosted: December 4th, 2017, 11:27 pm
by WaldemarHasz
Hi Milos

Here are some data:
• W10: VS2017
• Centos in VM (6.9 x64): XDebug (2.1.4); PHP (5.3.29)

php.ini:
;--------------------------------------------------------------------------------------------------------
; XDebug
;
; Notice:
; Port 9001 is used because nginx server uses port 9000 for FastCGI.
;--------------------------------------------------------------------------------------------------------
zend_extension=/usr/lib64/php/20090626/xdebug.so
xdebug.remote_log="/tmp/xdebug.log"
xdebug.profiler_enable = 0
xdebug.remote_enable=1
xdebug.remote_host = 192.168.2.1
xdebug.remote_port = 9001
xdebug.remote_autostart = 1
xdebug.remote_mode = req
xdebug.idekey="php-vs"

To link source code that resides in virtual machine I have Samba installed.
Then in Windows I I create a virtual folder:
mklink /d "E:\Podjetja\Nevron\Hospitality Interface\Design\PHP - VS2017\Iptv\Source" "\\192.168.200.254\Root\var\www\portal\library\Iptv"

So I get a Source folder under the project (unfortunately I couldn't make PHP tool to understand that files are on shared folder.. it would be cool if that could be possible).

I'm also getting a lot of "The program '[15784] php_remote.exe' has exited with code -1 (0xffffffff)."

Then in the middle of Single stepping if I wait a little I get a lot of:
The program '[3880] php_remote.exe' has exited with code -1 (0xffffffff).
Auto-attach to process '[16072] php_remote.exe' on machine 'WALDEMAR-PC' succeeded.
The program '[10576] php_remote.exe' has exited with code -1 (0xffffffff).
The program '[4104] php_remote.exe' has exited with code -1 (0xffffffff).
The program '[15784] php_remote.exe' has exited with code -1 (0xffffffff).
Auto-attach to process '[13832] php_remote.exe' on machine 'WALDEMAR-PC' succeeded.
.
.
.

And a lot of times the keypress simply doesn't work.


Then in VS I define Xdebu port: 9001 and use manual path mapping.


Do you want me to do any test/enable logging/....?

Best regards
Waldemar

Re: Issues with stepping in debugger.

PostPosted: December 6th, 2017, 9:37 am
by Miloslav Beno
Hi Waldemar,

I will have your environment recreated here and I will try to replicate this.

You can ignore the message from output pane. We should get rid of it as it's not important and "normal" during remote debugging.
The program '[15784] php_remote.exe' has exited with code -1 (0xffffffff)."

I know you've already mentioned it, but it would help tremendously to know what version you had previously and if this worked there. So I can audit changes in the debuger since then.


Thank you so much,

Re: Issues with stepping in debugger.

PostPosted: January 8th, 2018, 7:06 pm
by WaldemarHasz
Hi Miroslav

Sorry for the late response.. didn't see the notification email.

Previously I was using the version from the spring... have no clue which version, but I've updated to the new one after around 6 months.

Best regards
Waldemar