Phalanger Tools compiled project not running in IIS

Phalanger Tools for Visual Studio [?] is complete PHP/Phalanger integration into Visual Studio development environment.

Phalanger Tools compiled project not running in IIS

Postby Pirazi » February 13th, 2015, 12:43 am

Hi I'm new to phalanger and phalanger tools,

I'm trying to create a website that uses an assembly I've compiled. It seems to work fine in Visual Studios 2013.

But when I go to deploy it in IIS, I'm getting a class not found exception.

The steps I've taken:

1) Add the dll as a reference in the project.
2) compile project in release mode.
3) Copied the /bin directory, index.php and web.config to the server root

Error: Class 'TestClass/class1' not found in ...

What am I missing? Do I need to add something to the webconfig?

Thanks
Pirazi
 
Posts: 1
Joined: February 12th, 2015, 6:57 pm

Re: Phalanger Tools compiled project not running in IIS

Postby Jakub Misek » February 22nd, 2015, 9:47 am

Hi,

Phalanger compiles php files into DLL, so you don't have to copy index.php and other .php files to your root.

Copy DLL files from your BIN folder. Additional references should be added to web.config as follows:
Code: Select all
<phpNet>
    <scriptLibrary>
      <add url="bin/mydll.dll" />
    </scriptLibrary>
</phpNet>
Jakub Misek │ DEVSENSE s.r.o. │ Email: jakub@devsense.com
User avatar
Jakub Misek
 
Posts: 2058
Joined: January 4th, 2012, 2:42 pm
Location: Prague


Return to Phalanger Tools

Who is online

Users browsing this forum: No registered users and 1 guest

cron

User Control Panel

Login

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 62 on January 7th, 2012, 10:54 pm

Users browsing this forum: No registered users and 1 guest
Phalanger